Ensure the following OS packages/patches are installed
This one should be on the first Solaris install DVD
VIEW HBA’s:
Once the OS is updated and a reboot -- -r has been done check if SUN/Solaris is seeing the HBA's.
luxadm -e port
/devices/pci@1d,700000/SUNW,qlc@2,1/fp@0,0:devctl CONNECTED
/devices/pci@1d,700000/SUNW,qlc@2/fp@0,0:devctl CONNECTED
fcinfo hba-port -l |grep HBA
HBA Port WWN: 210000e08b1c829a
HBA Port WWN: 210000e08b1c2395
fcinfo remote-port -sl -p 210000e08b0c5518 > 210000e08b0c5518.out
fcinfo remote-port -sl -p 210100e08b2c5518 > 210100e08b2c5518.out
(Note added LUNS when available will be seen here as "unconfigured"
This shows HBA’s
luxadm -e port
/devices/pci@1c,600000/pci@1/SUNW,qlc@4/fp@0,0:devctl CONNECTED
/devices/pci@1c,600000/pci@1/SUNW,qlc@5/fp@0,0:devctl CONNECTED
luxadm -e dump_map /devices/pci@1c,600000/pci@1/SUNW,qlc@4/fp@0,0:devctl
luxadm -e dump_map /devices/pci@1c,600000/pci@1/SUNW,qlc@5/fp@0,0:devctl
Assign LUNs.
Cgfadm –al
Example output
c1::2200000c50401277 disk connected unconfigured unknown
cfgadm -c c1::2200000c50401277
Also command can be done globally for each controller:
cfgadm -c configure c1
cfgadm -c configure c2
Text in this file “my theory is” can mess finding new LUNs in Solaris 10.
Update sd.conf
vi /kernel/drv/sd.conf
Add new LUN IDs created on
After Solaris 9, this should not be needed. 10 does not need this.
update_drv -f sd
9 and 10 can do this. 8 will failed.
devfsadm
cfgadm -al -o show_SCSI_LUN
(Note added LUNS when available will be seen here as "unconfigured"
reboot -r
Create Label for LUN
c6t600A0B800021E8B90000536B456B26B3d0
/scsi_vhci/ssd@g600a0b800021e8b90000536b456b26b3
Since this is the Export directory for Solaris "export" is a good volume name. Solaris does
not like disks without a volume name (label).
format> current
Current Disk = c6t600A0B800021E8B90000536B456B26B3d0
/scsi_vhci/ssd@g600a0b800021e8b90000536b456b26b3
(SUN and Solaris see this as a known disktype)
select type 19
Enter 8-character volume name (remember quotes)[""]:"export"
Ready to label disk, continue? y
Saving new disk and partition definitions
Enter file name["./format.dat"]:
root@j2-apps01 # luxadm probe
No Network Array enclosures found in /dev/es
Node WWN:200400a0b821eab1 Device Type:Disk device
Logical Path:/dev/rdsk/c6t600A0B800021E8B90000536B456B26B3d0s2
Create New Filesystem on LUN/Volume
root@j2-apps01 # newfs /dev/rdsk/c6t600A0B800021E8B90000536B456B26B3d0s2
newfs: construct a new filesystem /dev/rdsk/c6t600A0B800021E8B90000536B456B26B3d0s2: (y/n)? y
/dev/rdsk/c6t600A0B800021E8B90000536B456B26B3d0s2: 1073676288 sectors in 32766 cylinders of 512 tracks, 64 sectors
524256.0MB in 10922 cyl groups (3 c/g, 48.00MB/g, 5824 i/g)
super-block backups (for fsck -F ufs -o b=#) at:
32, 98400, 196768, 295136, 393504, 491872, 590240, 688608, 786976, 885344,
Initializing cylinder groups:
...............................................................................
...............................................................................
............................................................
super-block backups for last 10 cylinder groups at:
1072703520, 1072801888, 1072900256, 1072998624, 1073096992, 1073195360,
1073293728, 1073392096, 1073490464, 1073588832,
This only needs to be done from one machine
/dev/rdsk/c6t600A0B800021E8B90000536B456B26B3d0s2
This will mount at boot
/export/home on /dev/dsk/c6t600A0B800021E8B90000536B456B26B3d0s2 read/write/setuid/devices/intr/largefiles/logging/xattr/onerror=panic/dev=1d80022 on Tue Nov 28
If you use Veritas follow these steps
# instruct veritas to scan for new luns
vxdctl enable
vxdisk -o alldgs list
c7t1d12s2 auto:none - - online invalid
/etc/vx/bin/vxdisksetup -i c7t2d11
vxdg init oraclelogs c7t2d11=c7t2d11
# if group already exists
vxdg -g oraclelogs adddisk c7t1d12=c7t1d12
vxdisk -o alldgs list
# vxdg free
# make a volume of max size (41853696)
vxassist -g oraclelogs make oralogvol01 41853696
## After making 19g check free space of new Volume
# vxassist -g oraclelogs maxgrow oralogvol01 Volume oralogvol01 can be extended by 2007040 to: 41852928 (20436Mb) # growto space available vxassist -g oraclelogs growto oralogvol01 41852928
vxprint -htr
mkfs -F vxfs /dev/vx/rdsk/oraclelogs/oralogvol01
mkfs -F vxfs /dev/vx/rdsk/oraclelogs/oralogvol02
mkdir /oralog01
mount -F vxfs /dev/vx/dsk/oraclelogs/oralogvol01 /oralog01
cd /oralog01
ls
df -h
vi /etc/vfstab
/dev/vx/dsk/oraclelogs/oralogvol01 /dev/vx/rdsk/oraclelogs/oralogvol01 /oralog01 vxfs 2 yes suid
# umount /oralog01
# mount /oralog01
1 comments:
I understand that the lun should be labeled. But what if the lun was previously connected to a different server and you run the risk of erasing files by doing so?
Post a Comment